Microsoft 365 degrated performance

Incident Report for Teamtel

Resolved

Most Microsoft 365 services have now been restored, including Office 365, Entra, Intune, and related web applications.
Some admin users may still experience limited access to the Entra or Intune admin centers while Microsoft finalizes recovery.

We’ll continue to monitor Microsoft’s service health for any further updates.
Posted Oct 10, 2025 - 12:53 CEST

Investigating

We’re currently observing degraded performance across several Microsoft 365 services, including Office 365, Entra, Intune, and various web applications.
This appears to be a widespread Microsoft issue.

Our team is monitoring Microsoft’s service health and will provide updates as they become available.
Posted Oct 09, 2025 - 10:35 CEST
This incident affected: Modern Workplace (Microsoft 365).