Service Disruption: 3CX Availability Issues Due to Datacenter Incident

Incident Report for Teamtel

Resolved

The network issues affecting several 3CX installations have now been resolved, and services have returned to normal operation.

The datacenter engineering team has restored service and continues to monitor the environment to ensure ongoing stability. In parallel, a detailed investigation into the root cause is being conducted, and efforts are underway to implement a permanent solution to prevent similar incidents from occurring in the future.

We apologize for any inconvenience this incident may have caused and thank you for your patience and understanding throughout the disruption.

This incident is now considered resolved. Further updates will be provided if additional relevant information becomes available.
Posted Sep 14, 2026 - 14:48 CEST

Monitoring

The cause of the earlier service disruption was traced to a failure within the datacenter network infrastructure. Traffic was successfully redirected to a secondary network path while remediation efforts were carried out.

The affected network component has now been restored and the vast majority of services are operating normally again.

The datacenter engineering team continues to closely monitor the environment to ensure service stability, and we remain in contact with them while monitoring continues.

If you continue to experience any issues with your 3CX system, please contact our support team.

We will provide further updates if necessary.
Posted Sep 14, 2026 - 13:31 CEST

Identified

We have identified the cause of the ongoing service disruption affecting several 3CX installations.

The issue has been traced to a network infrastructure component failure within the datacenter environment. Traffic is currently being redirected through a secondary network path while engineers work to restore the affected component.

Some customers may continue to experience service interruptions or degraded performance during this process.

Our team is closely monitoring the situation and working with all relevant parties to restore normal service as quickly as possible.
Further updates will be provided as more information becomes available.
Posted Sep 14, 2026 - 11:31 CEST

Update

We are continuing to investigate this issue.
Posted Sep 14, 2026 - 10:55 CEST

Investigating

We are currently investigating a datacenter outage affecting several 3CX installations. Users may experience service interruptions or reduced functionality.
Our team is actively working to identify the cause and restore normal operations. Further updates will be provided as they become available.
Posted Sep 14, 2026 - 10:55 CEST
This incident affected: Fixed Telephony (3CX Phone System, 3CX Hosting) and Teamtel (Phone).